Results 1 to 4 of 4
  1. #1
    Grand Thread Necromancer Desert Sage
    Join Date
    Dec 2012
    Location
    In your closet.
    Posts
    645

    Memory usage increasing fastly & then resets

    I get a lag spike every ~15 seconds when the memory usage increases to 99% and then resets to ~15%
    I have 4 gigs allocated and it's eating them up in 15 seconds.
    Probably a memory leak but it's happening in all 1.8.* versions when it didn't before.

    Media:





    Anyone having the same problem and/or knows how to solve it?

    Edit: Fixed, I had to change my JVM args
    Last edited by cdriza; 02-18-2016 at 08:38 AM.
    eee

  2. #2
    Glad you got it sorted. I'm curious what about your JVM args was causing the problem. Can you post the before & after arg strings? Thanks CD!
    Buddha say, "How do I get my pee-pee out of a soda can?"

  3. #3
    Grand Thread Necromancer Desert Sage
    Join Date
    Dec 2012
    Location
    In your closet.
    Posts
    645
    Quote Originally Posted by Oldthinker View Post
    Glad you got it sorted. I'm curious what about your JVM args was causing the problem. Can you post the before & after arg strings? Thanks CD!
    I didn't save the old args, sorry :V
    Here's the new args if you want them though.
    -Xmx4G -Xms4G -XX:+AlwaysPreTouch -XX:+UseG1GC -XX:MaxGCPauseMillis=50 -XX:+UnlockExperimentalVMOptions -XX:TargetSurvivorRatio=70 -XX:G1NewSizePercent=40 -XX:G1MaxNewSizePercent=50 -XX:InitiatingHeapOccupancyPercent=12 -XX:G1MixedGCLiveThresholdPercent=40 -XX:+AggressiveOpts
    eee

  4. #4
    hoo those are beefy args
    Buddha say, "How do I get my pee-pee out of a soda can?"

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •